
Making Animated Sprites
Making the Sprite Strip

1. Start by launching Adobe Illustrator.

2. Make a new document, but in the documents setup dialogue box 
change the units to pixels and the size to the typical room size in Gam-
eMaker… 640 x 480. Name the file your last name Sprite Strip Practice. 
Then click ok.

3. Select the Rectangle Tool from the tool bar along the left. 

4. With the rectangle tool se-
lected, click once anywhere on the 
page. In the new dialogue box that 
appears type 64 x 64 and press ok.

5. A new box should appear. This box is the size of four tiles in your game 
room. From breakout, going with small, at 32 x 32 caused a lot of detail in the 
image to be lost. Going with a bigger size sprite should help.  

6. To check the size choose View>Rulers>Show Rulers. Using the rulers as a 
gauge it should appear 64 x 64.

7. Since the next game is Pac-
man, and in the interest of keep-
ing the practice simple, Pacman’s 
mouth opening and closing will be 

the animation that is made. 

8. Start by selecting the Ellipse Tool from the tool bar along the left. It 
should be hidden under the rectangle tool so click and hold on the 
rectangle tool until the tool panel opens. Now select the Ellipse Tool.

9. With the Ellipse Tool selected, click and drag a circle that fits just right 
inside of the rectangle that was previously drawn. Remember to hold 
shift though so that the ellipse becomes a perfect circle. 

10. Just to be safe and make sure that Pacman isn’t too big to fit through 
the openings in the game room, lets scale him down just a bit. With 
the Selection Tool, click on the circle. Holding Alt and Shift on the 
keyboard drag the edge of the circle so that it’s just a tiny amount 
smaller than the box. 

11. The head is made, but Pacman needs an eye; just one though since 
this is a side profile of his head. Use the Ellipse Tool again but this 
time drag a small circle to make the eye. Remember that holding shift 
will make it a perfect circle. Without holding shift it can be a longer 
ellipse. 

12. Now that the head and eye is made, a little bit of planning and prepa-
ration must be done before making the mouth. Guides can be used to 
keep the mouth opening the same size through the sprite strip. The 
guides will not show up on the final animation but they will be visible 
for on screen prep work. This makes them perfect for planning. 

13. First, select the ellipse with the Selection Tool. When the ellipse is 
selected, there should be a node at the midpoint horizontally and 



vertically. From the top that measures left to right, click somewhere inside of it and drag a guide down to the 
midpoint node. Then from the vertical ruler click inside of it and drag a guide out to the other midpoint node.  
This should make a light blue cross hair over the center of Pacman. Remember that these lines will not print or 
be visible on the animation but have just helped point out the center of Pacman!

14. Now change the ruler’s origin to Pacman’s center. Click on the square 
in the top left corner where the rulers meet and drag it to the center 
of Pacman. Make sure the two points align just right and drop the 
point. The rulers each now start to measure from this point.

15. Now drag a guide out from 
the horizontal ruler and drop it at 2, 
4, 6, 8 and -2, -4, -6, -8. These will 
aid in opening the mouth incremen-
tally.

16. Now choose 
View>Guides>Lock Guides. This will 
make the guides unselectable and 
unable to move. 

17. Hold the Shift key and select the box, eye, and circle that form Pac-
Man. 

18. Hold Alt and Shift and click and drag the shapes over to the right over 
the original drawing. Make sure that the box lines up with the original 
boxes edge with no gaps between them. 

19. With all of the second drawing still selected, hold Alt and Shift and 
drag to the right again. Again make sure that the new one lines up 
with the second and first one.  Repeat this process until there are 7 
instances of Pacman all side by side.



20. Zoom in on the first Pacman instance in the strip and select the circle with the Selection Tool. 

21. Now that all the sprites are made it’s time to open his mouth. Choose the Scissors Tool form the tool bar. It may 
be under the Eraser Tool. If this is the case, click and hold on the Eraser Tool until the drawer opens and then 
select the Scissors Tool. 

22. Click once where the circle and guides at 2 meet and once where the 
circle and guide at -2 meet. This will cut out the section between these 
two guides. With the Selection Tool click on the line segment between 
these guides and delete it. Pacman’s mouth is now open!

23. Zoom in on the second sprite in the strip and select the circle on this 
sprite. Choose the Scissors Tool again. This time click once at the in-
tersection of the circle and 4 and again at the intersection of the circle 
and -4. Select that section that was just cut and delete it.

24. Move on to the third sprite and do the same thing as the first two 
times only at 6 and -6. Don’t forget to delete the cut off line segment. 

25. Cut the fourth sprite at 8 and -8. After the fourth his mouth will start to close again so the fifth should be 6, -6. 
The sixth should be 4, -4 and the seven should almost close at 2, -2.

26. Now each sprite in the sprite strip should have an opening in the circle. There needs to be more than just an 
opening though, there actually needs to be a mouth; something that resembles a slice of pizza!

27.  Since there is already a center found for the first sprite, this one will be easy zoom in on the first sprite and se-
lect the cut circle with the Selection Tool. 

28. Choose the Pen Tool, hover over the point at the top of the opening until the slash appears and the click once. 
Now go over to the vertical line that divides Pacman into two pieces, find where it intersects with the middle 
line and single click again. Finally mouse over to the bottom opening point. Once over it a circle should show up 
beside it. Single click once it does. This closes the shape and finishes the head and mouth.



29. The other 6 sprites in the strip do not have this vertical line in them 
yet. Without these, there isn’t a clear center. They need to have guides 
too. Select the circle that makes the head of the second sprite. From 
the vertical ruler, click and drag a guide out to the midpoint node and 
drop it.

30. Repeat the same process for sprites 3-7.

31. Now it’s quite simple. For each of the sprites in the strip, select the circle, choose the Pen Tool, click once at the 
top opening point once the slash shows up, click once at the very middle point of the circle, and again at the last 
point in the head (but only if the circle is showing up over the point). Repeat these steps to finish each of the 
remaining six sprites. 

32. The sprite strip is made! It was pretty technical, but to make sure that they are lined up the same spot without 
moving, this is how it had to be done! 

33. Click on File and choose Save As. Name the file Your Name Sprite Strip Practice.

Prepping for Export

34. The strip needs to be prepped a little before it can be exported. As it 
stands right now, the sprite would include a huge empty area the size 
of the white box or document in Illustrator and the strip would have 
a box around each sprite. These are two things to fix before it can be 
exported properly.

35. Choose File>Document Setup. When the new dialogue box appears, 
click the Edit Artboard button in the top right corner of the dialogue 
box. This will put nodes around the artboard. Click on the corner node 
and drag the corner nodes to resize the document so that the sprite 
strip just fits in. Once the document is resized, clicking on any tool will 
exit the artboard editing mode.



36. Now select and delete each of the sprite boxes so that they won’t appear in the game. 

37. Before exporting the sprite strip, add some color to Pacman’s body so it isn’t quite so boring looking. The strip is 

now ready to be exported. Choose File>Export. When the new dia-
logue box appears, change the Save as Type to PNG, choose the server 
as the saving location, and name the file your name Sprite Strip and 
then click Save. 

38. Another new dialogue box will appear. 
On this box change the resolution to screen 
(72 ppi) and the background contents to 
transparent. Finally, with both of these set, 
choose OK to close the dialogue box. 

39. Before closing Illustrator, click on 
File>Save As and save the document as Your 
Name Final Practice Sprite Strip. This will 
make a second version of the sprite strip. 
The first one has the boxes and can be used to determine the size of the sprite and the 
second is ready to go to GameMaker. 

40. The sprite strip is complete!

Adding the Sprite Strip to GameMaker

41. Launch GameMaker Lite.

42. Click on the red Pacman icon to make 
a new sprite. 

43. When the new dialogue box appears, 
name the sprite SPR_Pacman and then 
click on the Edit Sprite button.

44. A dialogue box will open. In it, choose 
File>Create from Strip. Find and select the 
sprite strip, then choose Open.



45. That dialogue box will close but a new one will open. Here, since there were seven Pacman’s in the strip, type 7 
for the number of images. All of the Pacman Sprites are side by side in 
one row so type 7 for the number of images per row. If done correct-
ly, the sprite’s image width and height should be 64 x 64. This can be 
checked by opening Your Name Practice Sprite Strip in Illustrator and 
selecting one of the boxes and checking it’s width and height in the 
options bar across the top. 

46. With these number entered into their respective boxes, there should 
be black boxes appearing in the sprite strip preview window. Take a 

look at them. Do the sprites fit in 
the box? Are they in evenly? If not, 
something is wrong with the numbers typed in the boxes. Fix them so that it 
fits and click OK to close the dialogue box.

47. In the other dialogue box that was open, the Sprite Editor, there should 
be seven separate Pacman sprites labeled image 0 through image 6. To the 
left of them there should also be a show preview check box. Click on it. This 
will show the animation of his mouth opening and closing. Click on the green 
check to close the Sprite Editor and then ok to close the sprite’s dialogue box. 

48. Congratulations! The sprite is made and animated!

Creating an Animated Object and Room

49. Now , to show off the new animation, click on the blue ball to make an 
object for Pacman. 

50. Name the object OBJ_Pacman and choose SPR_Pacman for the sprite.

51. Add a create event for the new object. 

52. Drag a move fixed action into 
the Actions area. 

53. In the Move Fixed dialogue box 
leave self checked, click on the right 
arrow and add 5 for the speed. Click 
ok to close the dialogue box. The click ok to close the object dialogue box.

54. Now when the game (which isn’t actually a game, but a way of showing 
off the animation) starts, Pacman will start moving to the right with his mouth 
opening and closing using the new animation based on the sprite strip. 



55. Now click on the white box icon to create a new room. This will open 
the new room and its properties. Check to see if OBJ_Pacman is 
selected and then click once on the left edge of the room to place it 
in the room. Pacman should fill four boxes if done correctly. Click the 
green check to close the room. 

56. Test the game to see Pac-
man walk opening and closing his 
mouth. 

57. Pacman should move from left to right and have an animated mouth. 
He does leave the room though so there is only a short while that he is visible.  
There is a quick fix for this.

58. Double click on OBJ_Pacman.

59. In the new dialogue box, click on the Add Event box, choose Oth-
er>Outside Room. From the Move tab, click and drag the Wrap Screen 
action into the Actions area. When the new dialogue box pops up, 
click OK and then ok to close the objects properties. 

60. Run the game. Once he exits right, he should enter on the 
left. 

61. That’s it! The animation is made and there is a room to 
show it off! Save the game and turn it in to get credit. 


